When trying to change the config file inside the vm of sonarqube container i am getting the below error


(ram) #1

I have containerised my sonarqube and running it successfully without any errors. But when i try to open it thorough the port it is not getting exposed. So i have tried to change the sonar.properties file inside the conf folder and when restarting the sonarqube container i am getting the following error.

and my sonar.properties file is

sonar.web.host=104.210.11.20
sonar.web.post=9000

when i try to open http://104.210.11.20/9000 . it shows the browsers can’t be reached


(Colin Mueller) #2

Ram,

sonar.web.host=104.210.34.56
sonar.web.host=9000

To be honest, I have no idea if this will fix the issue, but defining sonar.web.host twice will likely cause an issue. Try out sonar.web.port for size. When that is done, the proper way to navigate to a URL with the port specified is like this: http://104.210.34.56:9000

Some good news though: An Official SonarQube v7.4 Community Edition Docker image is just around the corner (like, already developed and waiting on approval into DockerHub level of around the corner).

Colin


(ram) #3

sorry its my typing mistake.

sonar.web.host=104.210.11.20
sonar.web.port=9000

i edited in my question


(Colin Mueller) #4

I thought that might be the case!

Well, I would also check to see that you don’t have another sonarqube instance running on that IP (a common cause of the “cannot assign address” failure).

Also: your screenshot shows 104.210.55.239, while your sonar.properties file shows 104.210.34.56, so something must be a little bit off on the configuration side.


(ram) #5

i changed my sonar.properties has
sonar.web.host=104.210.11.20
sonar.web.port=9000

and restarted my container
but it still shows the same error