Sonarqube public ip access issue

Template for a good bug report, formatted with Markdown:

  • versions used (SonarQube, Scanner, Plugin, and any relevant extension) 8.8
  • error observed (wrap logs/code around triple quote ``` for proper formatting)
  • steps to reproduce
  • potential workaround

P.S.: use the #bug:fault sub-category if you’re hitting a specific crash/error , or the #bug:fp sub-category for rules-related behaviour

Hi team,

properties
sonar.jdbc.username=sonar
sonar.jdbc.password=sonar
sonar.jdbc.url=jdbc:postgresql://localhost/sonarqube?currentSchema=my_schema
sonar.web.host=40.75.78.177
sonar.web.port=9000

I am getting the below response by using default settings but unable to access public IP of my Linux server after declaring sonar.web.host property. 9000 port is enable on public access.

Please help me no this.

default settings output

curl http://127.0.0.1:9001
{
“name” : “sonarqube”,
“cluster_name” : “sonarqube”,
“cluster_uuid” : “yFE5d9QfSsmeoyHLjooaCw”,
“version” : {
“number” : “7.11.2”,
“build_flavor” : “default”,
“build_type” : “tar”,
“build_hash” : “3e5a16cfec50876d20ea77b075070932c6464c7d”,
“build_date” : “2021-03-06T05:54:38.141101Z”,
“build_snapshot” : false,
“lucene_version” : “8.7.0”,
“minimum_wire_compatibility_version” : “6.8.0”,
“minimum_index_compatibility_version” : “6.0.0-beta1”
},
“tagline” : “You Know, for Search”

I’m sorry, it’s not clear what the issue is as you mention port 9000, but also show a curl of port 9001. Can you try rephrasing what the problem is?

If you are running SonarQube on port 9000 and can query it locally, but you can’t externally, I’d suggest you start looking at firewall rules, network security groups, etc. SonarQube probably isn’t the issue.

Hi colin

in Default i have set 9000 is my port but getting a response for curl http://localhost:9001 and curl http://localhost:9000 no response.

we have allowed all the IP range for inbound and outbound
but still unable to access sonarqube from an outside machine