SonarCloud doesn't notice the existing Github connection


I’m trying to add buy SonarCloud to my project.

I created an account using Github and started connecting my employer’s Github organization. I’m not a Github org admin, so Github requested approval and one of the admins approved the connection.

The SonarCloud “My Projects” page is still empty. I can click “Analyze new project” and “Import an organization from GitHub” to get redirected to Github. I select the organization and get “Update SonarCloud’s repository access”.

Everything looks fine: SonarCloud has access to the repo where we want to try it out. Full organization access isn’t granted and can’t be granted.
Clicking “Update” shows “This action must be performed by an organization owner” - which is also fine because I don’t need to update anything.

Github authorized SonarCloud but SonarCloud doesn’t know about it.

I tried to get around the problem by taking the installation ID from the URL of the Github screen shown above. I installed SonarCloud using my Github user as an organization which takes me to the “Create an organization” screen of SonarCloud which has the Github installation ID in the URL I didn’t complete the setup here and replaced the ID with by companies installation ID taken from Github before. This takes me to a message “You are not authenticated. Please log in and try again.”. Klicking the Github button to login via Github always returns to this page.

The SonarCloud support redirected me here.

How can I set up SonarCloud for my repo?

Thank you,

Solved by involving a Github admin to create the SonarCloud organization. Not really a solution, should be fixed in SonarCloud.

Hi @Sebastian_Willing

Thanks a lot for describing this issue and adding the workaround.
We should for sure improve our UX and our documentation to make this existing limitation explicit, and to work on it later on. We created internal tickets for that.

Have a nice day,