Unable to add project to application

I’m currently working with SonarQube Enterprise Edition - Version 9.2.4.

I am trying to populate an empty application that I created with a project, but I’m having trouble following the ‘Populating Applications’ section under ‘Managing Applications’. I do not see where to chose “Unselected” or “All” filter to add additional projects.

Looking at this thread, I tried looking in Administration>Configuration>Portfolios, but no portfolios or applications appear in that section (I tried creating a portfolio through this section but that also doesn’t appear on the page, despite showing up on the ‘Projects’ homepage).

When I go to the application through the ‘Projects’ homepage, it just says that it is empty.

Hey there.

I’m guessing that when you created the application, you didn’t get the right permissions on it to administer it.

  • You can find the Application under the global Administration > Projects > Projects Management (filter on Applications) and Restore Access from the gear menu
  • You should check the permission template being assigned when the Application is created and make sure Creators are granted Administer access

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.