Unable to add projects to an application

We use the Enterprise Edition v7.9.4.

I have created an application via the UI but I cannot add one of our projects to it. When I search for a project (using more than 3 characters) to add, nothing shows up. Even though we have dozens of projects in the system.

I’ve tried to use the Web API but cannot add projects with it either.

I can call api/applications/create successfully and the new application shows in the UI.

I can call api/applications/add_project successfully but the project does not show in the UI application.

When I call api/applications/show, I get a 400


Welcome to the community!

Have you tried this via the UI? The best way to master the API is to perform the desired action via the UI and eavesdrop to see which calls the UI made to accomplish the action.


Yes, I originally attempted to do this through the UI. I searched for the project to add, but none showed and we have dozens of projects in the system. I performed different searches (using more than 3 characters as I noted) and no projects show.

That’s when I tried to do this via the API


Two questions:

  • is it possible your ES index is corrupt? Do all your projects show up as you would expect in all the other places?
  • dumb question, but via the UI, you did look on the ‘Unselected’ and/or ‘All’ tab, right? (IMO this interface pattern is a little tricky):


I don’t see SELECTED buttons. In this image, I opened the new Application and selected the Projects tab so I can add a project. I searched for ALPS which is one of our projects but it didn’t show up in the search results:

In this image, I searched for ALPS in the main search box and it did show the ALPS project:

Also, what is the ‘ES’ index?


Okay! Screenshots are good. :smiley:
What you show in the first screenshot is the interface to see the projects that have already been added to the application. You need to edit the Application definition to add projects to it. I’m stretching to remember the UI in 7.9. I believe if you had permissions to do this edit your Application-level menu would end with an ‘Administration’ menu option. I think you’re going to need to get with an instance admin to get your permissions granted/and or your projects added.

Elasticsearch. But that’s no longer a real candidate in my mind.


Ahhh, the end is in sight and thank you. Do you know which specific perms I would need to add a project to an application?


You would need administer on the Application.

The fact that you created the Application & don’t have this perm points to a flaw/hole in your permissions template. Get your instance admin to add “Creators” perms to the template:

Okay, this screenshot is a bad example because we don’t have Creator perms on, but we don’t do a lot of creating and most relevant folks are in those blurred-out groups who do have perms.


1 Like