SonarQube showing old bugs after re-run the build

Hi Team,

Currently, I am using SonarQube version 9.3. We have faced below mentioned issues after upgrade to 9.3 from 8.2.x

  1. Most of the sonarQube rules are inactive state after upgrade to 9.3. (For example. Sonar way built in java - 16 rules are active, 500 + rules are inactive). Due to this issue, SonarQube report showing very minimum bugs. As we know that, default build in sonar way rules are not activated manually. so for time being, I took copy of sonar way rule and created new profile. Now I able to activate most of the rules. But still some of the rules are in active state. I have tried to clean up sonarqube_home/data/es7 directory and restarted. Still same issue. Could you please help why rules are inactive?

  2. Below mentioned rules are contradicting to each other
    a) An open curely brace should be located at beginning of a line
    b) An open curely brace should be end of a line

  1. Developer fixed the bugs (blocker) which is shown in sonarqube dashbaord. So We have re-run the build with correct branch. But still sonarqube dashboard showing same error after fixing the bugs.

  2. I tried to look inactive rules in sonarqube. For example, In Java - it shows around 140+ rules are inactive state. when i tried to look 140 + rules , it shows only 10 rules…Remaining inactive rules are not shown…I have tried to click load more option…But it does not load all inactive rules.

@ganncamp @Colin Kindly help me on this?

@ganncamp , Could you please help me on this?


As I mentioned in your other thread, items 1 & 4 certainly sound like corrupt Elasticsearch indices.

For number 2, yes, we’re aware. There’s a reason not all rules are turned on by default. Some teams will want A, and others will want B.

For number 3, more details are needed. Please open a new thread with the details, including perhaps some screenshots.



Thanks for your update