Some rules are not showing in SonarQube

Hi Team,

Currently I am using SonarQube community edition version 9.3. Below mentioned rules are not showing in sonarqube.

  • Assertions comparing incompatible types should not be made
  • AssertJ assertions with “Consumer” arguments should contain assertion inside consumers
  • JUnit5 inner test classes should be annotated with @Nested
  • JUnit5 test classes and methods should not be silently ignored
  • Regex boundaries should not be used in a way that can never be matched

Please refer below screenshot.

Also, I noticed that, Total inactive rules in java is 114. But sonarqube showing only 7 rules. I have clicked load more option as well. But it display 7 rules only.

I have tried to cleanup data/es7 folder and restarted. But no luck.

Any one please help on this?

@ganncamp @Colin

@necto @mpaladin @ganncamp

Kindly look into my issue. It will very helpful

Hi @Mahi, thank you for reporting this issue!

We do ask you to please be patient and avoid tagging users that are not already in the thread :pray:

This helps us be fair with everyone in the community :slight_smile:

1 Like

Sure, I will wait for response. Thanks for your reply and guidance.

1 Like


When you say you “cleaned up” the data/es7 folder… did you delete it? Because this certainly looks like a corrupt index.

And I suppose when you Show More, nothing happens?



Now issue has been resolved.

Initially, we deleted the <Sonar_home>/data/es7 folder and restarted. It does not work.

So , After I tried to delete <Sonar_home>/data/web/* & es7/* folder. Now built in sonar way rules are updated and showing correct rules. .

Thanks for your support Ann!