SonarCloud project search by name results being refreshed with the whole list of projects

, ,
  • Error observed

When searching for a project on SonarCloud with the autocomplete search, it will return the right filtered result, but 2 seconds later it will just replace the search results with the whole list of projects available.

  • Steps to reproduce

    • Open SonarCloud projects page for your organization (Projects Page URL template)
    • Search for part of a project’s name in an organization that contains many projects
    • SonarCloud will initially find it
    • After about 4 seconds it replaces the search results with the complete list of projects instead.

Hey Marcus.

Maybe this could happen on slower connections? I have trouble reproducing. A screen recording could be a big help here.

Hi Colin,

Thanks for your quick reply, here is a screen capture of the bug:

I am working from the office on a fairly good connection speed:

speed test

Also, my coworkers reproduce the issue either in their homes or from the office.

Hi Marcus,

Thank you for reporting the bug. Can you tell me what browser are you on?

I tried it on my side in Chrome browser and seems to be working well without any issues. Can you inspect this page using developer tools and check if there are any calls being made to the network while the new search appears?

Hi Sarath,

Thank you for your reply. I tried it with both Chrome and Edge with the same outcome.

I think there’s a racing condition for when we quickly type something on the search box and the list of project’s is still loading.

Reproduction steps:

  • Enter any value on the search box
  • Clear the search box
  • Enter right after that another value on the search box

My theory is that the search for when the search box is cleared takes longer to load than a filtered search and it gets “overridden” by it:
Search A : All projects
Search B: Only filtered projects

A----------------------------------> end

Hi Marcus,

We have created an internal bug to track this. We will let you know once we have a fix for it

1 Like

Thank you. Please feel free to reach me in case we can perform other tests to help you with this issue.


Hello @marcuslopes

The bugfix has been deployed this morning and you shouldn’t have this issue anymore.
Feel free to ping us here if you still encounter that issue.

Best regards,

1 Like