Migrated ADO to new Tenant

We recently migrated our ADO Org to a new AAD tenant and all our email addresses changed as a result. We’re seeing some strangeness with Sonar now. Obviously no one can access our account with their new email addresses. But we also see issues loading Organization settings, Azure DevOps connectivity management never loads (just spins) and we’re getting strange errors on pull requests:

##[error][SQ] Task failed with status FAILED, Error message: Project or branch in report (myorg_myapp-decode) does not match the project or branch under which it was submitted (adesacentral_auction-vin-decode:PULL_REQUEST:55105)

So the question is, what is the best way to get Sonar updated now that we’ve changed tenants?

Not sure why my post was hidden by the system… making an edit to unhide it

2 Likes

Hi,

You created this thread under SonarCloud, but I’m guessing you meant SonarQube?

 
Ann

We use SonarCloud the SaaS product, is this not the right place?

1 Like

Hello, any feedback from sonar?

We’re in the same boat as we were 5 days ago when I posted this. Teams are reporting additional errors now too:

This error is on 2 projects that worked fine this morning but have been failing this afternoon.

Project not found. Please check the 'sonar.projectKey' and 'sonar.organization' properties, the 'SONAR_TOKEN' environment variable, or contact the project administrator

We confirmed that we’re only getting the Project not found error on PR builds. It’s working just fine on all other builds.

1 Like

Hi @Nathan_Roe,

Welcome to the community!

Do you work with the OP, or are you facing this problem in a different company / tenant?

 
Thx,
Ann

1 Like

I work with Will. I’m just adding some more details that will hopefully help to narrow down the issue.

2 Likes

It just occurred to me that the “Project not found” error is only happening with Sonar projects that are setup with a monorepo. Projects that aren’t setup that way seem to be working just fine.

1 Like

Are you able to get us some assistance on this? Not really sure where to go from here.

We resolved the “Project not found” issue. The PA token that we had configured apparently didn’t have the correct permission to access the ADO repositories. We generated a new token with more permissions and it appears to be working now.

1 Like

Hello @wjdavis5,

Thank you for your patience. First, regarding the settings and connectivity management not loading, could you confirm if you are still experiencing this issue? We deployed a bug fix for it yesterday.

We are looking into the other issues at the moment.

Like Nathan mentioned in his last post we were able to figure out the issue by inputting a new PAT. I’m not sure why the existing PAT refused to work on some project and worked fine on other projects.