In the Marketplace, what does it mean for a plugin to be incompatible?

Hi, I just upgraded from SonarQube 6.1 to 6.7.7. For SonarJava, it automatically installed (it was before). In the Marketplace, when I hover over the available versions from 5.0-5.13, it says “Incompatible”. When I hover over 5.13.1+, it says “Requires system update”. What does it mean for it to be incompatible if it doesn’t require a system update?

I am seeing this with various other plugins as well, such as SonarPython, which had 1.8 automatically installed. I had to manually install 1.9.1 in order to get this bug fix (which is why I originally upgraded the server): [python:S1481] Code Smell: Unused local variables should be removed - False-Positive with string interpolation.

I could manually install newer versions of other plugins as well, but I don’t know if that’s safe.

I also can’t find an official plugin compatibility matrix, since this only shows 7.9+:

Hello @mpeters985

Well, logically I’d say that Incompatible means that you cannot have such a version on your SQ (maybe downgrading SQ could let you do that). While 5.13.1+ you could but you need to upgrade SQ first.

But none of this matters, you should not use 6.7 anymore as it is no longer supported and Marketplace entries about it had been removed. Any reasons why you were targetting this?

The server running SonarQube hasn’t been updated to Java 11 yet, so 6.7 is a temporary upgrade until that occurs, then we will go to 7.9+. In the Marketplace, SonarJava version 5.0 specifically lists “support for 6.7 LTS” in its abbreviated changelog message, which makes it seem like it should be compatible.

But since 6.7 is no longer supported and we should be going to 7.9+ before too long, I won’t worry about this for now and will revisit it after upgrading if the issue persists. Thanks!