Importing Organization to Sonarcloud From Azure DevOps

  • ALM used Azure DevOps
  • CI system used Azure DevOps
  • Languages of the repository C#
    We are new to sonarcloud, and trying to import organization but it is showing us this error “The token doesn’t have the required permissions (Code: Read & Write)” we have given correct permissions to the token but we are not able to import. We have checked organization name and permission, there is nothing which is blocking but we are still not able to import organization. we also tried to give full permission to see if this helps but again we have seen the same error message.
    See attached image.

this issue can be resolved by disabling Conditional Access under the organization settings or enabling conditional access for SonarCloud
Refer to the below image


@Colin_SonarSource @TomVanBraband
if we disable “Conditional Access” it will have some implications so we cannot go down this route.
Can we still utilize “SonarCloud” by enabling “Conditional Access”, do we know the IP address ranges for sonarcloud so we can whitelist them to enable communication.

1 Like

We don’t have fixed IP addresses for itself. IP addresses may change over time with workload and recycling of underlying resources: we do not guarantee permanent IP addresses.

See related discussion here.