Github com Pull request decoration not working on 7.9 LTS

Hi,
I am running SonarQube LTS in developer edition, version: 7.9.4.35981
I am trying to connect sonarqube decoration to appear on github.com pull request check for repos in a private organization.
I’ve followed the guide for Github Enterprise, created an app following the guide and on sonarqube sending the keys for marking a pull request, on sonarqube instance it appears as done, Passed without any warning or errors and on GitHub I don’t see any checks on the PR.

I tried so far:

  • going after the guide for Github enterprise integration (including creating a private key)
  • setup sonar.core.serverBaseURL variable

FYI: the sonarqube is accessible only to specific set of ips.

Did someone here managed to connect sonarqube 7.9 TLS with github.com?
Does someone here has a more detailed setup instructions for this process?

Hi Shay, welcome to the SonarSource Community!

Integration with github.com worked for a while in SonarQube 7.9 but was never officially supported. Since github.com deprecated and removed one of the APIs we depended on, PR decoration is no longer functional. If you’re aiming at integrating with and staying coupled to cloud-based SCMs, I strongly urge you to track our latest releases where we intend to remain compatible with them. github.com works perfectly well with SonarQube 8.6.

Hi Jeff, Thank you for the response

I will take the options into consideration, as migrating from LTS version – 7.9 to latest version - 8.6 might result in reduced maintenance (every 18 months, rather than every 2 months).

Do you know when the next LTS is expected to release?
I assume it would contain all 8.6 changes and github.com support

The 8.x LTS is expected by the end of Q1 2021. So yes, if you’re looking to stay on an LTS release that contains github.com support, this would be ideal.

(There’s also no reason to wait for github.com support, so long as you don’t mind upgrading to 8.6 now and then the final 8.x LTS release in a few more months. Then you can stay on the LTS after that.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.