Auto analysis failed and not recovering

Autoanalysis is enabled for a GitHub project, the first time it failed because the number of lines exceeded the plan limit. I found it odd as the documentation states those aren’t billed yet but I increased the limit anyway. It’s still not working, I deleted and recreated the project in SonarCloud but no effect.

It’s stuck on the screen

, what can I do? The properties file is already there.

Hi @plmaheu ,

Do you see any background tasks in the dedicated menu ? (“Administration” -> “Background tasks”)
If yes, can you provide us one of the latest task id related, so that we can check on our side what happened.
You also can see some warning maybe on the top right of the screen.


If I understand correctly, you could not get a project analyzed, so you recreated the project. That should not have been necessary. We could have helped you debug and fix it. The recreated project will probably have exactly the same problem.

If I understand correctly, the recreated project doesn’t even get analyzed this time. Note that the analysis is triggered by commits. So after importing the project, push a commit to the repository (the master branch or a PR). That should trigger the automatic analysis, let us know if not. And then it’s likely you’ll have the same problem as with the original. Please keep us posted.

1 Like

I thought that the analysis might be stuck in some invalid state even after I upgraded our plan. Apparently that wasn’t, it’s probably that I needed to trigger the analysis with some change. I did that later on, added an empty line to a file and it did trigger the analysis.

It’s just a bit counter-intuitive from an external perspective that the first analysis has to be triggered by a change in the repo. I can understand if you trigger an analysis only when there’s an incoming webhook, it’s just not obvious at first sight when setting up a new project.

1 Like

Totally. This tripped me off as well a few times, that’s why I jumped in on this thread :wink:

The good news is that we already have a plan to improve this, and we’ll soon begin to implement it, so stay tuned!