Trying to bind SonarLint with SonarQube in IntelliJ

I’m trying to bind SonarLint with SonarQube in IntelliJ (version 2023.2.2) I’ve installed the latest SonarLint plugin ( and it worked the first time that I added a new connection with my local host (http://localhost:9000/). However now it doesn’t finish after the step where i add the authentication token from SonarQube. Please advise?


Welcome to the community!

What version of SonarQube are you trying to connect to? If you’re not sure, you can check your page footer.


  • Version 8.9.9 (build 56886)


You’re trying to connect the shiniest new version of SonarLint to a EOL version of SonarQube. I’m willing to bet you’re hitting an API incompatibility.

Can you upgrade SonarQube and try again?


Hi Ann,
I upgraded to * Version 9.9.2 (build 77730) and it still won’t let me connect.


Thanks for trying the upgrade. Are you getting exactly the same behavior or has it changed any?


No change. Also I’m using my company issued laptop with Zscaler. If I try the same steps on my home PC, it works fine.

Hi @stiegjo,

Could you please try with instead of localhost? This is sometimes a proxy limitation that resolve both differently.

Also, a timeout of 1 minute should happen if the connection is hanging. Please enable the logs and share the full stack trace if that happens.


Thanks Nicolas. I tried but no luck. Which log should I look for? (I don’t see anything in the SonarLInt Log.

You can enable the Analysis logs and Verbose output in the tool window settings. You should have something logged inside the log tab when the timeout ends.

With your VPN active, is a simple ping working?

Where is your SonarQube service running? Is it from a docker container, for example?

I’m running SonarQube server from a docker container. Also I enabled the Analysis logs and Verbose output and now I see this error (I can also ping it):

Request failed
org.apache.hc.client5.http.HttpHostConnectException: Connect to [/] failed: Connection refused
	at java.base/ Method)
	at java.base/
	at java.base/
	at org.apache.hc.core5.reactor.InternalConnectChannel.onIOEvent(
	at org.apache.hc.core5.reactor.InternalChannel.handleIOEvent(
	at org.apache.hc.core5.reactor.SingleCoreIOReactor.processEvents(
	at org.apache.hc.core5.reactor.SingleCoreIOReactor.doExecute(
	at org.apache.hc.core5.reactor.AbstractSingleCoreIOReactor.execute(
	at java.base/

Thank you for the information you provided. Unfortunately, it’s difficult for us to act on this matter. The issue is coming from Zscaler, and unless you can share information proving that SonarLint is not working correctly, I recommend discussing this with your IT team.