There are no plugins available for DE

Hi !

I just migrated from CE to DE and I think there is some trouble:
1 - I cant SonarPHP plugin in marketplace
2 - I cant install pl/sql and swift due to :

Should I have converted the database for DE ?


I actually thought that most languages supported by core and not plugins

Moreover, the problem is deeper. I see only 15 available languages – only manually installed.

Hi @sporykhin,

Can you explain how you did the migration from Community to Developer Edition?
Normally, the mentioned languages are all natively in the Developer Edition binary, and you don’t need to install anything more.

Can you also send a screenshot of the bottom of your SonarQube UI?


thanks for your reply
that’s what i did:
1 - moved DB. pg_dump + pg_restore the corresponding DB to another place
2 - prepared docker-compose.yml to run
3 - started and applied for DE license


Hi @sporykhin,
you should follow the documentation on the upgrade path:
(especially while running a Docker installation, as we offer now official Docker images for commercial editions)

I would recommend to re-start the installation, as you will miss the additional languages offered in the Developer Edition.


As I understand there are no additional steps for CE to DE migration. they use the same DB schema. Am I right?

Right - If you’re asking about upgrading the schema SonarQube uses within the database, you don’t need to worry about it; SonarQube will take care of that itself.

Ok, thanks.
I use the official image without modifications.
I moved database and {url}/setup says " Database is up-to-date"
I mapped /conf, /data, /logs, /extensions, /temp dirs to host permanent volumes. I`m not sure about /conf directory but I haven’t found another way to map into container
In logs, I don’t see any errors

I can’t figure out what’s wrong with this dockerized installation :frowning_face:

Which version of SonarQube are you trying to install?
Can you send a screenshot of the SQ homepage (especially the footprint)?


Hi @sporykhin ,

did you reuse the extensions volume from the ce installation by any chance? this would explain why you are missing the de analyzers. the behaviour is explained to some extend here.
in order to fix this i would recommend that you recreate the extensions volume and let it populate by the new docker image in order to get the languages that you want.

hope that helps

Morning! No, the only one thing I reused is the DB

I recreated those folders and recreated docker-compose containers. /downloads and /plugin folders are empty

The folders or the named volumes?

sudo ls -laR volumes/extensions/
total 0
drwx------ 4 1000 1000 38 Sep 17 11:23 .
drwxrwxrwx 7 1000 1000 72 Sep  2 11:44 ..
drwx------ 2 1000 1000  6 Sep 17 10:28 downloads
drwx------ 2 1000 1000  6 Sep 17 13:02 plugins

total 0
drwx------ 2 1000 1000  6 Sep 17 10:28 .
drwx------ 4 1000 1000 38 Sep 17 11:23 ..

total 0
drwx------ 2 1000 1000  6 Sep 17 13:02 .
drwx------ 4 1000 1000 38 Sep 17 11:23 ..

Not sure what you mean

can you post your compose file?

for me it looks like you were using mounts instead of volumes. so in plain docker something like:

docker run -d -v /some/path/in/your/system:/some/path/in/container image:tag

currently this will result in the described behavior (empty folder so no plugins are available). This will change with the next release ( MMF-2042 ), but for now there are two ways to fix this:

If you are not planning on using 3rd party plugins (something that is not provided by sonarsource), you can just not mount anything to /opt/sonarqube/extensions in the docker image. as this folder is not declared as a volume in the Dockerfile, you can expect to have the official plugins and analyzers in there.

the second option is to use named volumes as stated in the documentation

Sure, no problem.

version: "3"

    restart: unless-stopped
    image: sonarqube:8.4.2-developer
    container_name: sonarqube
    hostname: sonarqube
    user: "sonarqube"
      - 9000:9000
    - sonar.jdbc.url=jdbc:postgresql://
      - /opt/sonarqube/volumes/temp:/opt/sonarqube/temp
      - /opt/sonarqube/volumes/logs:/opt/sonarqube/logs
      - /opt/sonarqube/volumes/data:/opt/sonarqube/data
      - /opt/sonarqube/volumes/extensions:/opt/sonarqube/extensions
      - /opt/sonarqube/volumes/conf:/opt/sonarqube/conf

looks like i was right. please see the suggestions about this in my previous comment :slight_smile:

one additional remark about the environment variables. the once that you are using are deprecated and will be removed in an upcoming release. please switch to the once that are documented here

1 Like

Thank you, the installation has reworked
But it would be nice to have more documentation about docker-compose/k8s installations