SonarQube warning

Hi SonaQube Support,
We are getting a warning for Node.js 18 is not recommended, you might experience issues. Please use a recommended version of Node.js [14,16]

We are running version 9.5 Enterprise edition. Do we need to upgrade to the latest version ?
Please advise.

Regards,
Bongani

Hi,

Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

9.5 → 9.9.2 → 10.2.1 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

Regarding your question, once you’re on a current version of SonarQube, you should be fine to use Node.js 18.

 
HTH,
Ann