Sonarqube service is active on server but URL is not working on browser


What do the logs say?


Service is getting active for few secs and if then im checking status is again failed,

That looks like the sonar.log file. What about the others in the /logs/ directory, like es.log?




Well, it looks like a couple things are going on:

  • Something is already running on port 9000 (you can adjust what port SonarQube runs on in your conf/ file. This aligns with the screenshot you shared earlier.
  • Your user may not have permissions to all subdirectories of the SonarQube installation folder. A chown -R should help here.
  • You’re trying to run as a root user, which is not allowed.

Thats what im getting now, if im switching the user to sonar

How to resolve this now?

It looks like the operation to change permissions failed – proably because your user doesn’t have permissions. You might need to sudo this one (the permissions change, not running SonarQube).

Yes that worked for changing the permission but still cant access the URL.

Now the Logs are:




Looks like we’re back here.

I tried with port 443 but its not working with that as well
Also 9000 port is open what i see on server but when im checking online its closed,

On Linux systems, typically all ports below 1024 cannot be listened on by programs executed by non-root users

It wasn’t happened on the previous server I did but cant now execute as a root user?