Sonarqube service running, but not allowing traffic to the default port 9000

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension): SonarQube.
  • what are you trying to achieve: Running sonarqube on the Ubuntu server for continous code analysis. However, sonarqube refuse to run on port 9000. The service is active in the server though.
  • what have you tried so far to achieve this: I have changed the port, uncomment the origin argument in the file too.


I recently installed sonarqube to include in continous code analysis pipeline for jenkins. Having installed the sonarqube and started the service with the sonarqube.service systemd file, Sonarqube service starts and is running in the server, however, I cannot access the service from the web browser using the ip:port or the configure reverse proxy url. I tried to curl the address in the server with localhost,, and even hard code the server ip address, all results did not solve the connection refused response.

Hey there.

Do the logs in the /logs/ directory of your SonarQube installation directory indicate that SonarQube is up and running?

Hi Colin,
The logs show the service is running including the elastic search which is running on port 9001.

Wrapper (Version 3.2.3)
  Copyright 1999-2006 Tanuki Software, Inc.  All Rights Reserved.

2022.06.24 12:31:32 INFO  app[][o.s.a.AppFileSystem] Cleaning or creating temp directory /opt/sonarqube/sonarqube-7.5/temp
2022.06.24 12:31:32 INFO  app[][] Elasticsearch listening on /
2022.06.24 12:31:32 INFO  app[][o.s.a.p.ProcessLauncherImpl] Launch process[[key='es', ipcIndex=1, logFilenamePrefix=es]] from [/opt/sonarqube/sonarqube-7.5/elasticsearch]: /opt/sonarqube/sonarqube-7.5/elasticsearch/bin/elasticsearch -Epath.conf=/opt/sonarqube/sonarqube-7.5/temp/conf/es
2022.06.24 12:31:32 INFO  app[][o.s.a.SchedulerImpl] Waiting for Elasticsearch to be up and running
OpenJDK 64-Bit Server VM warning: Option UseConcMarkSweepGC was deprecated in version 9.0 and will likely be removed in a future release.
2022.06.24 12:31:36 INFO  app[][o.e.p.PluginsService] no modules loaded
2022.06.24 12:31:36 INFO  app[][o.e.p.PluginsService] loaded plugin [org.elasticsearch.transport.Netty4Plugin]
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by io.netty.util.internal.ReflectionUtil (file:/opt/sonarqube/sonarqube-7.5/lib/common/netty-common-4.1.13.Final.jar) to constructor java.nio.DirectByteBuffer(long,int)
WARNING: Please consider reporting this to the maintainers of io.netty.util.internal.ReflectionUtil
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release```