Sonarqube server don´t started

I try since 3 days to start Sonarqube in many ways:

  • i change v.7.9 and v8.3 but the error is the same ( see attachement)
  • i followed the " Get Started in Two Minutes Guide" but the logs reports were same( see attachement)
    the localhost is free, i don´t understand why the report say Port 9001 ist busy.
    I also try to change the port but it not work and the error ist the same.

may someone help me?
(upload://93mDj7WzMSC6zfXJ2zhb9Eg24bs.log) (9.7 KB) sonar.log (19.3 KB)

Hi,

Welcome to the community!

Please check the other server logs and come back to us if the errors in them aren’t clear.

 
Ann

Hello thank you to answer me

I’ve read a few tutorials and tried something else.
but it did not work and here are the logs
es.log (10.3 KB) sonar.log (2.8 KB) web.log (6.4 KB)

here are the configurations file.
may be is something no correct
conf.zip (8.5 KB)

Hi,

From web.log it looks like maybe you uninstalled the C# analyzer…?

Aaand I’m guessing your on Developer Edition?

 
Ann

No, i install Sonarqube community

now i have this errors (see logs)- it is the same as my first post.
i only try to change the web Server port a free port -sonar.web.port=49669
Uploading: access.log… es.log (10.3 KB) sonar.log (3.0 KB) web.log (3.2 KB)

Hi,

The errors in your second set of logs indicate that you tried to (re)start SonarQube before the first instance was completely/properly shut down. That’s a guess. Really, anything could be holding port 9001, but SonarQube’s Elasticsearch thread is the most likely suspect.

And you haven’t answered this question:

 
Ann

i am not desinstall c# analyser.

when I did that, I didn’t know
I don’t know how to reactivate that.

Hi,

How about this: shut down your SonarQube server (if it’s still running). Throw away the SonarQube server directory, start fresh by re-exploding the zip, and let’s go from there.

 
Ann

ok i do it now

only these logs are been created

es.log (9.7 KB) sonar.log (19.3 KB)

web.log is not created

Hi,

Your es.log shows me this:

org.elasticsearch.transport.BindTransportException: Failed to bind to [9001]
...
Caused by: java.net.BindException: Address already in use: bind

You need to sort that out and try again.

 
Ann

how please? may i make some change into sonar propretiy file

i set “sonar.search.port=8000” in the sonar proprety file

the execute of “startsonar” don´t stop (see logs)
please help me to start sonarqube. firt only with the web server.

ce.log (1.2 KB) es.log (7.3 KB) sonar.log (2.5 KB) web.log (24.2 KB)

A post was split to a new topic: Server won’t start