Sonarqube plugin vb.net 3.0.3.346 will be compatible with sonarqube 6.7.4 or later version or not?

compatibility

(Priyanka Sharma) #1

Hi,
I have migrated my sonarqube 5.6.6 with sonarqube 6.7.4 and the plugin vb.net 3.0.3.346 was used in 5.6.6 sonarqube but after migration when I have looked for upgraded vb .net plugin it was commercial version which asks me to buy licence.So can I use older version of vb .net plugin with newer version of sonarqube?Or If there is any non-commercial version of vb.net is available for upgraded sonarqube then please suggest me.
Please help me with this ASAP.


Sonar process is being killed automatically
(Nicolas Bontoux) #2

Hi there,

A must-read for any compatibility query: https://docs.sonarqube.org/display/PLUG/Plugin+Version+Matrix

As you can see latest versions of SonarVB are required with LTS v6.7. And with respect to your note:

VB.Net analyzer was also a commercial analyzer in previous SonarQube versions. Upgrading to v6.7.x might definitely require a new type of license (packaging/licensing evolved) however you should be able to arrange that with your commercial contact directly (via which you licensed VB.Net analysis in the past).


(Priyanka Sharma) #3

Thanks a lot Nicolas. :slight_smile: