SonarQube not able to configure in Azure DevOps pipeline

I have .NET application and we have sonarqube server configuration with valid project.
I am trying to configure in DevOps pipeline but I am getting below error.

##[error]No agent found in pool which satisfies the following demand: java. All demands: msbuild, visualstudio, java, Agent.Version -gtVersion 2.144.0

Running this on self-hosted agent and it has all required softwares including java.
I am able to run my application without sonarqube run code analysis task.

Please help

You’ll want to dig into your agent capabilities to understand what isn’t being satisfied.

thanks for reply.
is this java version fine?

java version “” 2022-04-22
Java™ SE Runtime Environment (build
Java HotSpot™ 64-Bit Server VM (build, mixed mode, sharing)

I got it… added capability for java then it works fine… thanks much

New to SonarQube and today configured community edition to my On-Premises Azure DevOps Server and facing the same Issue. Installed JDK 17 and 19 but the issue was not resolved. I also tried with JRE 8 but still the same issues.

Please share step by step or screenshot-based configurations to check the Source Code Vulnerabilities.

Error as follows:

##[error]No agent found in pool which satisfies the specified demands: java, Agent.Version -gtVersion 2.144.0

Thanks in Advance.