SonarQube 8.3.1 Azure DevOps prerequisite Java version

Problem:
When Sonar’s Prepare Analysis Configuration task is executed in a pipeline, it fails with the error message:
“No agent found in pool which satisfies the following demand: java. All demands: msbuild, visualstudio, java, Agent.Version -gtVersion 2.163.1”

My question is, what version of Java should be installed in the agent where the pipeline runs? The error messages just tells “java” but not the version.

Versions I am using:

  • SonarQube Enterprise Edition / Version 8.3.1 (build 34397)
  • Azure DevOps cloud, with Java 14 installed in the agents

What am I trying to achieve?
I want to run Sonar’s Prepare Analysis Configuration task in an Azure DevOps pipeline

What I have tried so far?
Java 14 is already installed in the Azure DevOps agent that runs the Sonar’s task.

Thanks for your help!

Hi @jmsanchezcb and welcome to the community :slight_smile:
As of today, SonarQube doesn’t support officially Azure DevOps Services, only the on-premise version.
About your problem : if I remember well, SonarQube requires minimum Java 8 or 10, so you shouldn’t have this error message with version 14.
Maybe there is something that prevents us for detecting the java version.
Is it an official Oracle Java version (by opposition with a Java version from IBM or whatever)?

Kind regards,
Christophe

We tried again with 14, it worked this time. I guess we were missing something in the setup.

Thanks for your help!

1 Like