Java, Agent.Version -gtVersion 2.144.0

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)


  • what are you trying to achieve
    Integrated SonarQube for On-Prem Azure DevOps 2020 and getting Agent error in pipeline

  • what have you tried so far to achieve this

New to SonarQube and today configured community edition to my On-Premises Azure DevOps Server and facing the same Issue. Installed JDK 17 and 19 but the issue was not resolved. I also tried with JRE 8 but still the same issues.

Please share step by step or screenshot-based configurations to check the Source Code Vulnerabilities.

Error as follows:

##[error]No agent found in pool which satisfies the specified demands: java, Agent.Version -gtVersion 2.144.0

Thanks in Advance.

Hi Pavan,

When I search on the root of your error message,

I find indications that this is on the Azure side. You should make sure your versions are up to date.

That said…

None of these JDK versions is going to be helpful. Per the docs, SonarQube needs Java 11.


Thanks for your reply, Ann, which was resolved and now facing a new issue, Once please check it and if possible, please share the steps to resolve the issue.

The Issue as follows:–

Help : Version: 5.0.2. More Information


Please create a new thread for your new topic.


Sure, Thank you.