SonarQube helmchart change password hook and SONAR_WEB_CONTEXT

I’m using the SonarSource helm chart to deploy into GCP. The ingress is shared between several applications, so each needs a prefix to it’s path, so the root for sonarqube is:

This I have set up and working fine, with the ingress path and the SONAR_WEB_CONTEXT environment variable set to /sonarqube/.

However, the script run by change-admin-password-hook does not work, as it expects the api endpoints to be under http://service:port/api when in this case it’s http://service:port/sonarqube/api. I tried setting a rewrite rule on the ingress so the SONAR_WEB_CONTEXT setting could be removed, but while this allowed the password hook to succeed the sonarqube web interface wasn’t reachable and just displayed a page with ‘Loading…’ on it. I tried a suggestion for a similar sounding issue, but that didn’t help.

I was able to get this to work by taking a copy of the helm chart and changing the url used in the hook. Is there some way to get this all to work together, or does the helm chart not cover this use case currently?

Hi @James_Robson_SM and welcome to the community :wave:

good observation! This is indeed something that was forgotten. I have created DOCKER-38 to track this and resolve it as soon as possible.

Thanks for the report on your finding :slight_smile:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.