SonarQube login gets redirected back to the login page after entering the admin username and password

I am trying to install Sonarqube using helm from repo : helm-chart-sonarqube/charts/sonarqube at master · SonarSource/helm-chart-sonarqube · GitHub

In values.yaml, i have given the below values;

deploymentType: “Deployment”
replicaCount: 2

enabled: true
- name:
path: /sonarqube
serviceName: sonarqube-sonarqube
servicePort: 9000 Exact|Prefix|ImplementationSpecific(default)
pathType: Prefix
annotations: traefik

initialDelaySeconds: 60
periodSeconds: 30
failureThreshold: 6
sonarWebContext: /sonarqube/

initialDelaySeconds: 60
periodSeconds: 30
failureThreshold: 6
sonarWebContext: /sonarqube/
sonar.web.context: /sonarqube

initialDelaySeconds: 30
periodSeconds: 10
failureThreshold: 24
sonarWebContext: /sonarqube/

With these configuration, i tried deploying sonar. But i was getting readiness probe failure. So i had given the ingress path which in my case is /sonarqube as an environment variable in deployment file as below,

value: /sonarqube

After this, the pods are running and i am able to see the login page, But after entering the admin username and password(username: admin, password: admin), it is again getting redirected to the login page. Its not getting logged in.
If i give a wrong password, then i get the authentication error message.

Is there anything, i am doing wrong?

Hi @nithin_vithayathil ,

i think you already created an issue on the GH repo of the chart, can you confirm? Answered you there

Thank you Tobias. Changing back the replicaCount to 1 worked. I also had to add the below to environment variable

name: sonar.web.context
value: /sonarqube

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.