SonarQube docker images

Hi Eugene,

We have installed SQ 7.1 DE and when it comes to branch plugin I got following:

That’s why I thought it is not available in this particular docker image.


You should also get the license plugin installed and one more menu option under Administration -> General, I think.

But that is all. Now we are both stuck with this version. We have bunch of updated for plugins like Java or Git but we cannot install them since we require 7.3+. :smiley: Nevertheless, enjoy.


@maciej.ptak If you are still looking for a Docker image for SQ 7.4 Developer Edition, I have a Dockerfile you can use to build your own. It’s based on the last official Dockerfile from SonarSource.

1 Like

@gteshome , :+1:
I am afraid that this is the only option now…
For example, we already have an internal ticket to build docker image out of pretty much similar Dockerfile.

Thanks Gash, awesome, I was looking just looking for this.

1 Like

We’ve just released official images of SonarQube Community Edition 7.4 and 6.7.6, available on the hub.

We don’t plan to release images of the commercial editions at the moment, but it’s definitely on our radars.



@gteshome, In using your Docker image (thank you!), have you tried to apply a Dev license to the image to determine if the dev edition is functional when using the image?

How can I add custom .jar files to the image, such as code scan?


When trying to build this docker image with:

docker build -f Dockerfile-sonarqube -t sonraqube:developer .

It seems to be stuck half way:

  • mktemp -d
  • export GNUPGHOME=/tmp/tmp.Z6xU0byEc5
  • gpg --keyserver --recv-keys 0x036a9c25bf357dd4
    gpg: keybox ‘/tmp/tmp.Z6xU0byEc5/pubring.kbx’ created

Am I doing something wrong?

Try this

  1. Use --batch for gpg command
  2. use keyserver hkp://
  3. use keyserver hkp://
  4. use key B42F6819007F00F88E364FD4036A9C25BF357DD4 and F1182E81C792928921DBCAB4CFCA4A29D26468DE
  5. look here for reference: (it builds but is not guaranteed to work)

That got me a bit further. Now I am stuck on:

  • gpg --batch --verify
    gpg: Signature made Mon Oct 29 11:41:33 2018 UTC
    gpg: using RSA key CFCA4A29D26468DE
    gpg: Can’t check signature: No public key

Thanks. Got it solved using the link you provided.
Now I have an image. Let’s see if I can get it running now.

Pity: starting a container with this image fails with:

standard_init_linux.go:190: exec user process caused “exec format error”

@AndrewG Yes, this works with the developer license our company has.

To add the jar, the easiest thing to do is to build your own image by getting the Dockerfile and files, put them in a directory on your computer, add a copy of the jar in the same directory and add a line like this to the Dockerfile:

COPY <file>.jar $SONARQUBE_HOME/extensions/plugins .

@Marjo_Hartman I don’t think you’re doing anything wrong. When I have a problem at that step it’s usually because the keyserver is unreachable. Switching the keyserver as @degree recommended is the easiest solution.

That error is usually because the binary format of the executable doesn’t match the system it’s running on. How are you running the image?

Is there already a schedule for the Developer Images?

The gist I have posted earlier is updated with one line: USER sonarqube. I have managed to build the image and run it at least locally. Analysis does not work without a valid license.

FYI all, with 8.2 we’re adding official Docker images for Community, Developer and Enterprise Editions.

At this writing, I believe they’re still pending on the Docker side, but expect them any minute now!



This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.