SonarQube becomes slow after PostgreSQL upgrade

Hello SonarQube Operators!

It’s common that after performing an upgrade of PostgreSQL, a SonarQube instance connected to a PostgreSQL database can become painfully slow.

Thankfully, we know how the issue can usually be addressed (it works almost every time!): by executing the following command against your Postgres database.

VACUUM FULL ANALYZE

For a PostgreSQL database, a VACUUM FULL command reclaims unused storage, while the ANALYZE command updates statistics used by the planner to determine the most efficient way to execute a query (thank you Postgres documentation! :slight_smile: ).

It’s possible that AUTOVACUUM is already enabled for your database which runs these commands at regular intervals. Executing these commands manually can solve the immediate performance issue rather than waiting for the daemon to run.

If you face performance issues after upgrading the version of Postgres used, this should be the first action you take.

Do you still need some help? Raise a topic on Get Help > SonarQube

Colin

3 Likes