[SONARJNKNS] Side effect after upgrading SonarQube Scanner for Jenkins plugin from 2.6.1 to 2.7.1

sonarqube

(Antonio Matos) #1

Hello fellas,

Reopening the topic started on the old Google Groups. On the last update from Julien Henry (May 29th), it would be tried to reproduce the issue. Since there is no newer version than the 2.7.1 itself, I assume it still under investigation?

Is there anything I can do to help? As of now, we are still running old version 2.6.1, as we do need to run multiple Sonar analysis in the same Jenkins run. Any feedback will be much appreciated.

The original topic on Google Groups is:
https://groups.google.com/forum/#!topic/sonarqube/2q5lU5vWTxs/BM5eQFK_CwAJ

Thanks


(Julien Henry) #4

Hi Antonios,

Thanks for the ping. I have reproduced the issue, and created a ticket:
https://jira.sonarsource.com/browse/SONARJNKNS-299

I submitted a fix, if you want to test on your side, you can use:
https://repox.sonarsource.com/sonarsource/org/jenkins-ci/plugins/sonar/2.8.0.1851/sonar-2.8.0.1851.hpi

++


(Antonio Matos) #5

Awesome Julien, thanks for the feedback. I’ll use your beta version and run a few tests on our QA environment. Will let you know the results.

Regards


(Antonio Matos) #6

Hello Julien,

I finally had some spare time to validate the fix. It worked on all scenarios it failed using version 2.7.1.

I also checked GitHub and saw the fix was pretty simple, reversing the analysis list (last things first right?).

Again, thanks for your efforts helping us with that. I’ll be waiting for the new 2.8 version to come.

Regards


(Julien Henry) #7

Thanks Antonio, we’ll proceed with the release soon.