SonarCloud Gitlab Org import

Unable to import Gitlab Org in SonarCloud. I am already the owner of the group and have api permission provided for access token. Anyways How can I solve or debug this problem?

1 Like

Does Sonarcloud maps with name or id/key of the group for Gitlab? After mapping and moving to plan/payments the 3rd step, it is giving the same error after the payment step. [An Unexpected error occurred. Please try again later.].

1 Like

Hey @Madhvik_Patel

I reached out via private message for your organization details. Please respond there.

I am facing the same issue, the same error on payment.
I am the owner of the group on GitLab and payment is failing with an error [An Unexpected error occurred. Please try again later.] !!!
Any suggestion?!

Hello @Madhvik_Patel,

To answer your first question, you need to provide Group ID from the GitLab side when importing in SonarCloud.
If you still have the issue would you please retry while using the network tab in your web navigator debug tool to identify the failed request? You can ping me here and then I’ll reach out to you via DM to get all this information to help us investigate the issue.

Regards,
Nawar

I have the same problem, I am receiving error code 500 for the create API call in the last step of importing organization. Could you help me with this issue? if you can send me a private message, I can share a screenshot of the error I am experiencing.

After checking with @Reza_bagheri, the problem was resolved by using the existing users to continue their GitLab integration.