Create an organization - The request cannot be processed. Try again later


I try to get Sonarcloud integrated with Gitlab. I fill in the GitLab group key and the personal access token and I validate but I’ve got the following error message

[The request cannot be processed. Try again later.]

  • The permission for the token is “api” as required in the documentation and the group key is the top parent key id of the organization.
  • I tried as well with the group id of my group [] but I’ve got the same error message.
  • I tried again with fresh tokens
  • I deleted my account and created it again but I’ve got the same error message.

Would any of you have an idea about this issue or any proposition to go through?


Hello @MrVega,

To import a Gitlab group you have to be an admin of that group. Is that the case for you?
From the logs on our side it seems that you are not a member of the group you are importing.

Hi Tom, thanks for your explanation, it’s clear now.
In my organization, the admin team doesn’t give the admin permissions at the top level group. There is no chance for me to get it in anyway now or later.

Do you plan to allow the feature at a sub-group level or for a specific project id. Does it make sense for you ? It will be great for my team