Sonar scanner version compatibility check

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube 6.7.3, Scanner 2.8, Plugin sonar4bamboo, and any relevant extension)
  • what are you trying to achieve - where to find the sonar scanner version compatibility list with sonarQube
  • what have you tried so far to achieve this-- googled around. cant find the big list, only found the
    https://docs.sonarqube.org/latest/analysis/scan/sonarscanner/ saying that latest sonar scanner 4.0 compatible with sonarQube 6.7

Hi,

Welcome to the community!

Sorry, but we don’t keep a compatibility matrix for old versions. The latest scanner version will always work with the current SonarQube version and the current LTS.

On the topic of LTS, the new LTS was released this month, so you should upgrade to 7.9.1 at your earliest convenience. (All current scanners are compatible with it. :wink:)

 
HTH,
Ann

Hi Ann,

Thanks for your response and help. We are currently using SonarQube 6.7.3 (the previous LTE), Bamboo 6.7.3, scanner 2.8. Not sure when will we upgrade Sonarqube 7.9.1(current LTE). Will the curent versions work perfectly? Or you recommend upgrade scanner to 4.0?

Regards,
Peter

Hi Peter,

It’s difficult to say off-hand. Let me turn this around. You say you’re currently using these versions together. What is prompting you to ask these questions? Are you having problems?

 
Ann

Hi Ann, I haven’t see errors from the log. suppose it works still. Just wonder if there is any recommendations. But I think we are good to still use 2.8.
Thanks,
Peter