Sonar.leak.period being override

fix_the_leak

(Caio Cunha) #1

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
    • SonarQube Version 7.3 (build 15553)
    • SonarJS 4.2.1 (build 6529)

Hey there. We have a SonarQube server configured with Leak Period of 7 days globally. I set the sonar.projectVersion to BASELINE and run an analysis. I can see the version BASELINE.

I then changed the sonar.projectVersion back to what it was before (1.0) and set the property sonar.leak.period=BASELINE in the sonar-project.properties.

I re-run the analysis, but when I launch the page, I still see Leak Period: 7 past days as opposed to BASELINE.

Is sonar Leak period supposed to be supported per project?

Thanks,
C.


(Colin Mueller) #2

Caio,

The sonar.leak.period property can only be set through the global/project administration UI, not passed along through analysis (scanner) parameters, such as those that would be set in a sonar-project.propeties file.

Colin


(Caio Cunha) #3

Hi Colin.

Thank you for your answer. I cannot find in the UI any “Project” administration section.

I looked at Administration, look at all the tabs and their sub options. Also looked at Administration > Configuration > General > Leak, but can’t find a way to set it per project.

Where would that be in the dashboard?

Thank you,
C.


(Colin Mueller) #4

Navigate to your project dashboard, and a similar “Administration” tab appears.

Colin


(Caio Cunha) #5

Thanks Colin.

My issue is that although I was the system admin, I did not have admin permissions on the project itself.

I added myself as an admin and the Administration options did show on the dashboard.

Thank you again.
Caio.