Sonar Failing with Error Disable Automatic analysis, but the Automatic analysis is already disabled

Must-share information (formatted with Markdown):

  • SonarQube version 4.3.0.3225
  • how is SonarQube deployed: Gradle Task
  • what are you trying to achieve : Sonar coverage analysis by passing Jacoco xml report
  • what have you tried so far to achieve this
2024-01-24 14:11:49 INFO   Found 1 artifacts. Starting to download to: /workdir
2024-01-24 14:11:50 INFO   Successfully downloaded "api/build/reports/jacoco/test/jacocoTestReport.xml" 2.1 kB
Downloading https://services.gradle.org/distributions/gradle-8.5-bin.zip
............10%.............20%............30%.............40%.............50%............60%.............70%.............80%............90%.............100%
Welcome to Gradle 8.5!
Here are the highlights of this release:
 - Support for running on Java 21
 - Faster first use with Kotlin DSL
 - Improved error and warning messages
For more details see https://docs.gradle.org/8.5/release-notes.html
Starting a Gradle Daemon (subsequent builds will be faster)
> Task :api:sonar FAILED
FAILURE: Build failed with an exception.
* What went wrong:
Execution failed for task ':api:sonar'.
> You are running CI analysis while Automatic Analysis is enabled. Please consider disabling one or the other.

Hey there.

Can you share a screenshot of what you see under the project Administration > Analysis Method? Are you sure there might not be a similarly named project in your organization?

Thanks for taking the time to respond @Colin

Project name is Unique, however it has names with similar prefix

Example of my project

Repo 1 Name : test
Repo 2 Name : test-service

Under Administration > Analysis Method it shows as

As discussed in this form Automatic analysis can't be disabled - #5 by Lucas_Paulger , i have removed the project from sonarcloud, added sonar-project.properties to the repo to the main branch and added the repo again to sonarcloud, this time the status of the project is shown as below in sonarcloud, however the CI build is still failing as Automatic analysis is enabled.

CI Failure

I’ve reached out for some private details (the affected project key)

@Colin Thanks for responding , Issue seems to be resolved, after i attempted with adding sonar-project.properties and removed sonar properties from gradle task.