SAML/SSO authentication

SonarQube Community Edition 8.9.6.50800

I am trying to integrate SonarQube with SSO provider JumpCloud using SAML. I have tried changing attributes, verified that the URL is set to HTTPS, verified there is no load balancer, no matter what it will not work.

This is what I see in the logs every time I attempt to authenticate with SAML:

Caused by: com.onelogin.saml2.exception.Error: SAML Response not found, Only supported HTTP_POST Binding
at com.onelogin.saml2.Auth.processResponse(Auth.java:689)
at com.onelogin.saml2.Auth.processResponse(Auth.java:699)
at org.sonar.auth.saml.SamlIdentityProvider.processResponse(SamlIdentityProvider.java:149)
… 52 common frames omitted
2022.01.11 19:15:05 WARN web[AX5Ll9HefEUpyAsRAAC/][o.s.s.a.AuthenticationError] Fail to callback authentication with ‘saml’
java.lang.IllegalArgumentException: Provider login must not be blank

Does anyone know if there is resolution to this? Has anyone else seen this issue? Every solution I have found is a few years old and is no longer relevant to my situation.

Hey there.

Where are you initiating the login from? JumpCloud or SonarQube?

Both. Neither work and give me the same error.

Thanks @theofficefan

To be clear – we only expect that SP (service-provider) initiated login will work. Often we see this error log when a URL intended for IdP initated login is used – could that be the case?

Here is my configuration:



Sorry, I meant to also say that SP initiated does not work in addition to IdP not working.