Quality Profile Rules are not showing after migration

Hi All,
After i migrated from sonarqube:8.5.1-community** to ** Version: sonarqube:9.3.0-community`.
All our Quality Profile(Sonar way) rules are not showing up, it just display the count and not actual rules.
All the quality rules in Sonar way are in inactive state and not displaying .
Even i have tried to create a copy of builtin Quality Profile and activate rules, but unable to apply rules.

My earlier ticket regarding the migration Migrating Sonarqube - Database Upgrade Error

See attached screenshots.


@Carine_Bayon Any help is appreciated

Regards
Parasappa

Hey there.

It seems your ElasticSearch indexes have fallen into a bad state. They will need to be rebuilt.

How is your values.yaml configured? Is persistency enabled?

Persistency

SonarQube comes with a bundled Elasticsearch and, as Elasticsearch is stateful, so is SonarQube. There is an option to persist the Elasticsearch indexes in a Persistent Volume, but with regular killing operations by the Kubernetes Cluster, these indexes can be corrupted. By default, persistency is disabled in the Helm chart.
Enabling persistency decreases the startup time of the SonarQube Pod significantly, but you are risking corrupting your Elasticsearch index. You can enable persistency by adding the following to the values.yaml :

persistence:
  enabled: true

Leaving persistency disabled results in a longer startup time until SonarQube is fully available, but you won’t lose any data as SonarQube will persist all data in the database.

Hi @Colin,
Yes persistence is enabled.
Could you please guide me how to rebuild ElasticSearch indexes?
Thanks
Parasappa

Hi,
I’m able to fix by doing below steps

  1. Disable persistence volume and redeployed the helm chart.
  2. Delete pvc and pv
  3. Restart the pod.
  4. Enabled back persistence volume and redeployed the helm chart.
    Thanks
    Parasappa

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.