PR Decoration in Azure DevOps

Hi Team,

I am using Azure DevOps to run PR analysis.

During that, I see it shows the issues in Azure DevOps as shown in below image:
image

I also see there is an option to mark the issue as resolved, won’t fix, closed, etc… but when I mark any issue as resolved, closed, pending or any of the option it doesn’t fix any issue in SonarQube nor it allows me to complete the PR(as the quality gate status will still be failed)

Same if I mark the issue’s as resolved on SonarQube, then it immediately reflects on Azure DevOps.

Is this default behavior? Is it one-way communication?

Thanks,
Abhishek

Hi @aanvekar001

Yes, this is the normal behavior.

Mickaël

Thanks for the quick response @mickaelcaro

Is there an option to disable that?? can I remove the option to mark the issue as active, pending, etc… and also comment.

Because that doesn’t sync’s data with SonarQube.

Hi,

This option cannot be desactivated on the UI. The only way i see is to delete the PAT that you setup on the project, you will get a warning but comments will not be posted anymore.

That doesn’t make sense for me because If I delete the PAT then I wouldn’t be getting the quality gate status on PR.

I have policy to check the SonarQube Quality Gate status, based on which I will decide whether to complete or cancel the PR.

Indeed yes, sorry, so there’s no other way to not post comment yet.

Not a problem, thanks for your help.

I have a question on Setting the reference branch through sonar.properties, it there any sonar property for that ?? right now the only option I see is to set it from UI.

Thanks in advance

Not sure what you meant here : what are you calling reference branch ?

In the new release of sonarqube 8.4.1, there is a new feature rolled out for “new code” as reference branch.

I can set this from UI, is there any option to pass this as sonar.properties file?

Thanks,
Abhishek

Hi @mickaelcaro any update on this??

Hi @aanvekar001
There is no way to pass this option with the sonar.properties file.

Kind regards,
Christophe

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.