Only seeing only ½ of the results when filtering rules

System: SonarQube Developer Edition, Version 9.9 (build 65466)
We are not able to show all results from SonarQube rule list view - to be more precise “Show more” button at the end of the list does not work when results are filtered. It prevents from listing all results - we are not able to review security rules.
How to replicate:

  1. Go to “Rules” view from top menu
  2. Apply filtering so that results are limited, for example: Language: XML, Type: Bug, Vulnerability, Code Smell or Security Hotspot
  3. Information bar says there are 5 results displayed out of 10
  4. Clicking “Show more” has no results. We are always seeing only half of search results.
    Could you please tell is if this is by design or is there a setting that need to be adjusted since as for now seems we are only seeing only ½ of the results when filtering rules.

Hey there.

Just to make sure I know which “show more” you’re talking about – can you share a screenshot?

Hi Colin,
Please find attached screenshot

Hey there.

This seems like an issue with your Elasticsearch index. Can you try:

  1. Stopping SonarQube
  2. Deleting the data/es8 directory from the SonarQube installation directory
  3. Restarting SonarQube

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.