No (SVN)author information in code view after analysis


(Igor Pfeifer) #1

Hi,

I’m missing the author information in the code view after the analysis like shown in your documentation:
https://docs.sonarqube.org/display/DEV/Adding+an+SCM+Provider

I’m using the following software versions

  • SonarQube V7.2
  • SVN Integration 1.7.0.1017
  • Our SVN Server is 1.8.3
  • SQL Server 2014

The SCM Sensor in the SCM settings in the Administration area is not deactivated => So the default value. I have added a SVN user and entered the password. The SVN user is the same user as for the jenkins-build server.

Is there anything else I have to do to enable this functionality?

Thank you very much

Igor

Edit: I’ve entered the value “svn” in the field “Key of the SCM provider for this project”
Now the build fails and I get the following error.

ERROR: Error during SonarQube Scanner execution
java.lang.IllegalStateException: Error when executing blame for file


(G Ann Campbell) #2

Hi Igor,

Before you filled svn in for that setting, what if anything did your analysis logs say about retrieving blame information?

Also, are the SVN files present in your checked out project (SVN adds a directory containing its tracking files IIRC). Blame should be working automatically in your analysis based on those files.

Ann


(Igor Pfeifer) #3

without filling the “svn” setting I get the following log entry:
INFO: No SCM system was detected. You can use the ‘sonar.scm.provider’ property to explicitly specify it.


(G Ann Campbell) #4

Hi,

That brings us to this part of my response:

Ann


(Igor Pfeifer) #5

thanks for your reply. I’ll check this :slight_smile:


(Igor Pfeifer) #6

Issue solved :slight_smile:

“Also, are the SVN files present in your checked out project (SVN adds a directory containing its tracking files IIRC). Blame should be working automatically in your analysis based on those files.”

=> This was the first issue. Thank you

But I had another issue. The blame didn’t work for a specific file. This file is above 1.5MB big.
I’ve excluded it from the analysis process.

Now it works perfectly.

Thanks for your help.