Missing blame informations (SVN)

Hello everyone,

I got a problem with SCM integration (SVN) in SonarQube. Indeed the scanner can’t retrieve the blaming informations as you can see in the image below so SonarQube can’t assign automatically the issues to the developers.


I tried to do svn blame manually on some files that is mentionned in logs and it works.
I don’t know where the problem can come from…

Our setup is composed of :

  • A container Jenkins in 2.376 wich contains
    • The plugin SonarQube Scanner for Jenkins in 2.15
    • SonnarScanner for UNIX in
    • SVN 1.14.1
  • A container SonarQube in 9.7.1 (build 62043)

The SVN user/password are set in SonnarScanner options, the SCM Sensor in SonarQube is enable and the key of SCM provider is set aswell.

Thanks in advance.

Hey there.

You should be able to learn more about what’s happening when blame is (attempted to be) retrieved by turning on debug logging. You can do this by appending -X to the scanner command, such as sonar-scanner -X.

Hello Colin,

Thanks to your advice, I solved my problem !


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.