Missing blame information problem

Teamcity 2020.2.2
SonarQube 8.3.1 (build 34397)
Plugins:

  • C# Code Quality and Security 8.6.1 (build 17183)installed
    *Git 1.11.1 (build 2008)installed
    *JaCoCo 1.1.0 (build 898)installed
    *Java Code Quality and Security 6.3 (build 21585)installed
    *SonarCSS 1.2 (build 1325)installed
    *SonarFlex 2.5.1 (build 1831)installed
    *SonarGo 1.6.0 (build 719)installed
    *SonarHTML 3.2 (build 2082)installed
    *SonarJS 6.2 (build 12043)installed
    *SonarKotlin 1.5.0 (build 315)installed
    *SonarPHP 3.3.0.5166installed
    *SonarPython 2.8 (build 6204)installed
    *SonarRuby 1.5.0 (build 315)installed
    *SonarScala 1.5.0 (build 315)installed
    *SonarTS 2.1 (build 4359)installed
    *SonarXML 2.0.1 (build 2020)installed
    *Svn 1.9.0.1295installed
    *VB.NET Code Quality and Security 8.6.1 (build 17183)installed
    We are working with teamcity to execute SonarQube analysis. The source code repository is now bitbucket . We just passed svn to bitbucket. Some projects are give a warning message in sonarqube report . this message is “Missing blame information for 6408 files. This may lead to some features not working correctly. Please check the analysis logs.”
    but we can not find anything. scm settings are below. we think , it can be author information .Some projects receive author information, but some do not. we can see blame info in git history.

Hi,

Welcome to the community!

First, your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.3.1 → 8.9.2 → 9.1 (last step optional)

Regarding your actual question, I’m a bit confused whether you’re using SVN or Git with the problematic projects. Could you provide the log of an analysis with this problem?

 
Ann

we use git. log file is below:

Test_PayFlex.E_1.32.0_4._Static_Code_Analysis_SonarQube_7.zip (1.4 MB)

Hi,

You need to change your SVN password.

I see in the log you provided that you’re specifying /d:sonar.scm.provider=svn, as well as credentials on the command line.

Then in the log I see hundreds of line pairs like this:

[15:27:41] :	 [Step 3/3] 15:27:41.010 DEBUG: Process file Application/ApplicationService/PayFlex.E.ApplicationService.Contract/DTO/TransactionService/EnvelopeInquiry/EnvelopeInquiryRequestDTO.cs
[15:27:41] :	 [Step 3/3] 15:27:41.280 DEBUG: File Application/ApplicationService/PayFlex.E.ApplicationService.Contract/DTO/TransactionService/EnvelopeInquiry/EnvelopeInquiryRequestDTO.cs is not versionned. Skipping it.

Presumably that’s because there’s no SVN information for them, since you say you use Git. So it looks like you need to clean the SVN parameters out of your analysis command.

 
HTH,
Ann

thank you. it worked. we used`/d:sonar.scm.provider=git’

Hi,

There’s no need to specify the provider at all. It will be read from the directory. Just drop the parameter altogether.

 
Ann