New issues reported on non existing files

Hi Community,

Last Spring I upgraded our sonarqube from 7.7 to 8.3.1 34397 and I migrated mysql db to postgressql db at the same time. we use CVS as SCM and jenkins as our build tool, sonar is used for JAVA projects

Every night we run a sonarqube scan on our projects, this has been running without any problemes since the upgrade. then a couple of days ago, one of the projects, nolonger passes the quality gate, everytime the scan is run it detectes 3 new blockers and 1 new critical issues.


This should be fine, but if I go into the issues list, no issues are shown, instead new files has been created with text starting with “AWG4T…” , these files are not a part of our project, and all new issues are reported on those files. Every time sonarqube scan is run, the number of issues on the new files is increased.

If i go to source code, there is no new sonar issues, that time wise compares to the new issues, sonar is reporting.

Solutions tried,
Delete the sonarqube_home/data/es6 folder and restartet sonarqube - no effect
Delete Jenkins .sonar/cache - no effect

Anyone run into a simalar issue?
or someone that can help with a solution to this?


Hi Daniel,

Welcome to the community!

You haven’t upgraded your server since the spring. But have you recently upgraded or added plugins?

It would be useful to see what rules the ghost issues are coming from. How about a screenshot of that expanded facet?


Is correct that server has not been update since, no plugins has been change before the problem ouccured, but last friday CVS plugin was add, but again that was after the problem have ouccured.

Yes you can have a screenshot of the rules.

hope it helps :slight_smile:

Found another ticket with the same issue as we had,

After reindexing my postgres db, as he did, all issues are shown again in sonarqube

so my problem is solved :slight_smile: :smiley:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.