Need SonarQube Plugin Version Matrix for migrate from sonar 4.5 to sonar 5.6

Hello,

I need sonar matrice plugin in order to migrate from SonarQube 4.5 to SonarQube 5.6.
I use this plugin :
sonar-checkstyle-plugin-2.3.jar
sonar-clover-plugin-3.0.jar
sonar-cobertura-plugin-1.6.3.jar
sonar-css-plugin-1.1.jar
sonar-findbugs-plugin-3.2.jar
sonar-java-plugin-3.1.jar
sonar-javascript-plugin-2.4.jar
sonar-l10n-fr-plugin-1.13.jar
sonar-ldap-plugin-1.4.jar
sonar-pdfreport-plugin-1.4.jar
sonar-pmd-plugin-2.3.jar
sonar-useless-code-tracker-plugin-1.0.jar
sonar-web-plugin-2.3.jar
sonar-xml-plugin-1.2.jar

Thanks in advance for any help

I believe any SonarQube version less than 6.7 is not supported.
Here is the link to plugin matrix beyond v6.7.
https://docs.sonarqube.org/display/PLUG/Plugin+Version+Matrix

1 Like

That’s why i plan an upgrade to sonarqube 6.7 but i need matrix for versions priors sonarqube 6…

Keep the old matrix versions seems to be a very good idea …

Hi,

We kept the old data for ~1.5 years after 6.7 became the LTS, then dropped it because maintaining it does impose a burden.

You may be able to deduce the correct versions by looking at the individual plugins’ release histories and choosing a version released around (just after) the date of the initial 5.6 release, which you can see here if you “Show all versions”.

That said, I can make a few comments about individual plugins:

  • clover - this plugin is no longer maintained. You’ll do best to just rip off the bandaid and switch to JaCoCo
  • cobertura - ditto
  • css - the one you were using was provided by a community member who took his toys and went home. A SonarSource-maintained analyzer is available for 6.7 (but I think not embedded). Maybe just leave this out until you get to 6.7 and then you can install the latest
  • java - the correct version will be embedded with the platform
  • javascript - ditto
  • l10n-fr - this isn’t under heavy maintenance but AFAIK not incompatible. You can probably just upgrade to the latest version, 1.15.1, and be fine
  • ldap - go for the latest version. I’ve checked compatibility, and it will be fine
  • pdfreport - this stops working at some point. Honestly I forget the details, but best to just drop it now IMO
  • web, xml - ditto java, I believe

 
Good luck on your journey!
Ann

Thanks for your help !