My issue list is never working

After assign the issue to team members, the ‘my issue’ tab is not showing any issue.

Hi,

Welcome to the community!

To be clear, the team member to whom you’ve assigned the issue doesn’t see it on the ‘My Issues’ tab?

Are they looking at the project level or at the global Issues page?

Is it possible that the team member has multiple representations / accounts in SonarQube (e.g. one for the SCM account and one they actually log in with) and the issue is being assigned to the wrong one?

 
Ann

We are using SonarCloud ,not SonerQube.
I found one post mention rebuild the index to resolve this issue on SonarQube.

Hi,

Oops. Sorry I overlooked that. But my question remains:

 
Ann

Anyone can login our account to check ?

Hi,

Could you answer the question?

 
Ann

None of the members can see it.

Hi,

Can you see it? Could you provide a screenshot, please?

 
Ann

I assign the tickets to myself:

Nothing is shown on my issue list:

1 Like

Hi,

This is perfect. Thanks!

I’ve flagged this for expert attention. And in the meantime, do you have any errors in your browser console?

 
Ann

Hi @JanetZ ,

I’m investigating the issue you face with the My Issues page.
Could you confirm that all the issues you assigned to you are not on the main branch of your project, but on any other branch?

If so, could you try to assign to you any issue on the main branch of your project, and confirm to me the behavior of the My issues page?

Thanks in advance for your help,
Claire

Yes, The issue assigned are in other branch not in master branch .

Will update to you when we enable the master branch later.

1 Like

No error are showing on browser.

Hi,

As of today, the My Issues page shows only the issues assigned to you that belong to the main branches of your projects.
It is a known limitation, but still, it is misleading.
I got in touch internally with our product owners, to inform them of that behavior, in case we could rework that page to make it better.

Have a nice day,
Claire

1 Like

Thanks for your reply.

1 Like