JavaScript and/or TypeScript rules were not executed. Only Node.js v8 or later is supported, got v6.15.0

Currently running SonarQube CE Version 8.0 (build 29455)
with the following plugins
SonarJS Code Analyzer for JavaScript 6.1 (build 11503) (prev 5.2.1 Build 7778)
SonarTS Code Analyzer for TypeScript 2.1 (build 4359) (prev 1.9.0 Build 3766)

I have recently updated some plugins in SonarQube, namely SonarJS and SonarTS. but on new scans the project activity has dropped considerably and I am getting a warning

JavaScript and/or TypeScript rules were not executed. Only Node.js v8 or later is supported, got v6.15.0.

Is it worth rolling the extensions back to the previous versions or best to keep the most latest versions in place.

Greetings,

Analysis of Javascript and Typescript now require NodeJS v8. If you want to keep using the latest versions of our analyzers (and I think you should!), you really have two options:

  • Upgrade the version of NodeJS installed on your machine
  • Have multiple versions of NodeJS installed, and point to the newer one with the sonar.nodejs.executable analysis parameter

Colin

Thanks Colin, that seems to have worked. Thank you.

As a point of reference, do you need to add the sonar.nodejs.executable in to the Additional Settings of the Prepare the SonarQube analysis Build Step. Or can you add it Globally into the SonarQube Instance in the sonar.properties file?

As a test, I installed a second version of node.js and added it as a parameter in the additional settings as such with the full path inside quote marks.

/d:sonar.nodejs.executable="c:\Program Files\node-v13.2.0\node.exe"

thanks
Nigel

A post was split to a new topic: Where to install Node