Issue filter by rule does not work in version 10.2.1

We were working on version 9.7 and in the issues tab you could filter by rule, whether it was from Sonar or another analyzer like roslyn or stylecop, as long as there was an issue when filtering, they would appear.

We have recently updated to version 10.2.1 and now in the issues tab when filtering by rule it only finds sonar rules, while the rest ignores them.

When the Rule section is displayed, all the rules appear ordered by the number of occurrences regardless of the analyzer, being able to access the explanation of the rule, but when filtering it ignores them.


Thanks for this report. Could you provide a little more detail here, please:

Are you saying that you can’t filter by rules provided by 3rd-party plugins? By the rules underlying external issues? Something else?


I include some images of an example.
When the project compilation information is sent to SonarQube we can see that in the list of issues in the Rule section we can see the complete list of issues:


If we select the first rule we can see that it is from roslyn and the code for it:


If I enter the code in the search box the result is that nothing is found:


If the same is done with a sonar rule, we do obtain a result in the search:

This works in version 9.7.

I try with CAxxx, CSxxxx, IDExxxx, VSTHRDxxx rules with the same result.


Thanks for clarifying! This additional detail is very helpful.

From testing on Next (our dogfooding instance), it seems that this still works, but the search string needs to include the external_roslyn: part.

When you look at a native rule, the key is presented in the format of [rule repository key]:[rule key]. So java:S1874. In the case of external issues, there is no underlying repository in SonarQube supplying the rules, so the whole thing is considered the key (I guess). And yes, the difference in the way this behaves is pretty confusing.

And since you say this worked differently in previous versions, I’m going to run it by the team to see if the change was on purpose.



I try to search in Issues - SonarQube the string external_eslint_repo:no-useless-escape and the string no-useless-escape and both work, but in my SonarQube installation I try to use external_roslyn:CS8602 and I obtain “No results”.


Hi Eugenio,

Thanks for these new details. This has been referred to the product team & they’re looking into it.


Hi Eugenio,

Thank you for the detailed report!
We can reproduce on our side, there seems to be a problem with the ‘types’ filter that is used when searching for rules, which most likely comes from a rule indexing issue.
This ticket was created to investigate the issue further SONAR-20764.