Is Database upgrade required when we upgrade from Sonarqube 6.4 to 6.7.5


(Naresh) #1

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)
  • what are you trying to achieve
  • what have you tried so far to achieve this

Hi All,

We are currently planning to upgrade sonarqube from 6.4 to 6.7.5.Could you please help in providing below details required.

1.) Is there any database upgrade required when we are moving from 6.4 to 6.7.5 version ?
2.) How can we retrieve old reports,rules and profiles to the newly upgrade sonarqube version(6.7.5) ?

Thanking you in Advance.

Regards,
Naresh


(G Ann Campbell) #2

Hi Naresh,

Each version of SonarQube is likely to perform some upgrades to its database schema. Triggering that manual step is covered in the Upgrade Guide.

If what you’re asking about is compatibility with the underlying database engine, you’d do best to check the Requirements and Upgrade Notes of your target version.

 
Ann