I'm not able to login at sonarqube because of redirect to login page

which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)

Im at sonarqube developer edition version 8.9.10.

how is SonarQube deployed: zip, Docker, Helm

Docker

what are you trying to achieve

Im trying to log in

what have you tried so far to achieve this

I changed the machine to a production one at azure and redeployed my docker. My Server ID has changed and I asked for a new license id to make it work again, but since I updated the license Iā€™m not able to log in.

To fix it I tried only to reset the machine and log in again, several times. I found out that login calls some endpoints when login in and all of them return 401. But it is the administrator account and do not show authentication failed error.

This is the error returned for every endpoint called at login click:

  • api/authentication/login - 200 Ok

  • /api/users/current - 200 Ok

{
    "isLoggedIn": true,
    "login": "admin",
    "name": "Administrator",
    "local": true,
    "externalIdentity": "admin",
    "externalProvider": "sonarqube",
    "scmAccounts": [],
    "groups": [
        "sonar-administrators",
        "sonar-users"
    ],
    "permissions": {
        "global": [
            "admin",
            "gateadmin",
            "profileadmin",
            "provisioning",
            "scan",
            "applicationcreator"
        ]
    },
    "showOnboardingTutorial": false,
    "homepage": {
        "type": "PROJECTS"
    },
    "settings": []
}
  • /api/navigation/global - 200 OK
{
    "canAdmin": true,
    "globalPages": [],
    "settings": {
        "sonar.lf.enableGravatar": "false",
        "sonar.lf.gravatarServerUrl": "https://secure.gravatar.com/avatar/{EMAIL_MD5}.jpg?s\u003d{SIZE}\u0026d\u003didenticon",
        "sonar.technicalDebt.ratingGrid": "0.05,0.1,0.2,0.5",
        "sonar.developerAggregatedInfo.disabled": "false",
        "sonar.updatecenter.activate": "true"
    },
    "qualifiers": [
        "TRK",
        "APP"
    ],
    "version": "8.9.10 (build 61524)",
    "productionDatabase": true,
    "branchesEnabled": true,
    "instanceUsesDefaultAdminCredentials": false,
    "multipleAlmEnabled": false,
    "edition": "developer",
    "needIssueSync": false,
    "standalone": true
}
  • api/rules/app - 401 Unauthorized
  • api/editions/show_license - 401 Unauthorized
1 Like

Can I delete my instance and just create a new one from scratch and it will work?

Hi,

Welcome to the community!

Your version is past EOL. You should upgrade to either the latest version or the current LTS at your earliest convenience. Your upgrade path is:

8.9.10 ā†’ 9.9 ā†’ 10.1 (last step optional)

You may find these resources helpful:

If you have questions about upgrading, feel free to open a new thread for that here.

If your error persists after upgrade, please come back to us.

 
Ann