How to run build without build-wrapper?

sonarcfamily

(Vladimir Jendrol) #1

Hi,

I’ve tried to run build with build-wrapper and it failed with following error:
$ ~/build-wrapper/build-wrapper-linux-x86-64 --out-dir ~/project/build-wrapper-out/ ./build.sh
...
build-wrapper: connect to /tmp/build-wrapper-socket.MiMWkT: No such file or directory

Now I would like to run build without build-wrapper, but it seems that interceptor is still active.
$ ~./build.sh
...
build-wrapper: connect to /tmp/build-wrapper-socket.MiMWkT: No such file or directory

I’ve tried to find it in the environment variables and in ld configuration.

Is there some way to run clean build?

Versions:
build-wrapper, version 5.1 (linux-x86)
Ubuntu 16.04.1 x86_64


(Loïc Joly) #2

Hello Vladimir,

By ourselves, we don’t keep anything alive after a message such as this one. What could happen is that one of the processes used to build your code remains alive (for instance, because it uses a build daemon, which is not a supported case, you should instruct it not to do so).

So I think the first step to investigate would be, as always, to provide us with the logs (build-wrapper.log). The second would then be to look at the list of active processes on the build machine, if some of them look like processes that take an active part in the build.

Finally, a reboot would probably correct the issue, without understanding where it came from (which means it can repeat itself…)

Anyways, I guess a more interesting question would be: “How to run build with build wrapper?”… Fortunately, the same logs that you can provide to answer your question can probably also be used to answer this one.


(Vladimir Jendrol) #3

Hello JolyLoic,

Thank you. It was indeed caused by not ended build process.