Unable to build using build-wrapper-linux-x86 for C Code | execvp: No such file or directory

Must-share information (formatted with Markdown):

  • which versions are you using (SonarQube, Scanner, Plugin, and any relevant extension)


  • what are you trying to achieve

I’m trying to run scanner on C and C++ code. I have specific build commands for it. More on that is mentioned below.

  • what have you tried so far to achieve this

I have tried to run the usual build command build-wrapper-linux-x86-64 --out-dir bw-output <insert_your_clean_build_command>

I have been trying to use the wrapper to build to generate the *build-wrapper-dump.json* file.

The exact command I’m running is build-wrapper-linux-x86-64 --out-dir bw-output cd 5g-cpe/L3 && source .settings_file && make clean all

I’m getting this output build-wrapper: execvp: No such file or directory

I really some help with this. When I remove build-wrapper-linux-x86-64 it works just fine. I don’t know what am I doing wrong here.

Welcome to the community, @deep_c!

The command that you are using is with the build-wrapper is consisting of three parts:

  • changing dir (cd 5g-cpe/L3)
  • loading environment variables (source .settings_file)
  • actual build (make clean all)

I would suggest separating them, and passing only the actual build to build-wrapper. In other words, invoke the following one by one.

  • cd 5g-cpe/L3
  • source .settings_file
  • build-wrapper-linux-x86-64 --out-dir bw-output make clean all

For further investigation, please share your build-wrapper.log generated in bw-output file? If you think this file contains private information, let us know, and we’ll send you a private message that will allow you to send it privately.

Hey Tomasz, thank you so much for the welcome and quick reply.

The solution you provided worked big time and saved me a lot of debugging.

Thank much again.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.