Error 414 : URI Too Long

Must-share information (formatted with Markdown):

  • Version: SonarQube 9.9.1.69595
  • how is SonarQube deployed: zip
  • what are you trying to achieve: trying to access issues from a number of projects using a (/api/issues/search?componentKeys=project_tags)
  • what have you tried so far to achieve this - Able to get the issues up to a certain number of keys (let’s say 100)

I am trying to map the issues reported on SonarQube to relevant Jira Projects (using SonarQube Connector for Jira plugin).

Please don’t just push this issue plugin maintainer OR Jira, as I thought the same way and have already reported it to them.
Reported to Jira ( )
Reported to excentia - plugin provider (https://community.atlassian.com/t5/Jira-Content-Archive-questions/How-many-sonarQube-projects-can-be-linked-to-one-Jira-Project/qaq-p/2389793#M272556 )

Here is the summary:
As part of mapping viewing sonarQube issues on Jira board, we are using a plugin called “SonarQube Connector for Jira” which is added to our Jira Cloud.
Basically we are mapping a number of sonarQube projects to it’s relevant Jira Project using project_keys. Upto certain number of keys it is working fine. But when we are using more number of projects like 200 it is producing “414 Error: URI Too Long”.

Even I have tested the same URL using curl on sonarQube server
image

Jira community and excentia people are suggesting to check sonarQube configuration to adjust this length using a web,config file of Apache or Nginx. But we are not using any specific web server. I am guessing webservers like tomcat or jetty might have been embedded into SonarQube application.

Please provide a quick fix to this issue ASAP.

Thanks
csrvsk

Can someone please respond with some inputs to address this issue ASAP.

One more update this issue is,
When requested curl for this URL on the sonarQube server itself along with a token, we are able to get the proper response.

Now the issue is only accessing this lengthy URL on a web browser.

Thanks in advance.

Hi csrvsk,

Per the FAQ, you’re not guaranteed a fast response here. Commercial support, on the other hand, does have an SLA.

You’re using a 3rd-party plugin that uses our APIs in an unintended manner to accomplish an integration we recommend against. I’m not sure I have many other options. That said…

You, yourself have demonstrated that the problem does not lie with SonarQube. I suspect you have a proxy - probably IIS, which is notorious for a too-short URL length limit - in the middle that’s the underlying problem here.

You should talk to your network folks.

 
HTH,
Ann

1 Like